RPC Rate Limiting
Incident Report for Helium
Resolved
This incident has been resolved.
Posted Apr 21, 2023 - 17:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2023 - 17:05 UTC
Investigating
It appears that the upstream RPC service which serves the wallet app has gone into a rate limiting mode. This appears to cause wallet balances to temporarily appear empty. We are investigating the cause.
Posted Apr 21, 2023 - 16:54 UTC
This incident affected: User Apps (Helium Wallet App) and Helium App.