Explorer Unavailable
Incident Report for Helium
Resolved
This incident has been resolved.
Posted Aug 23, 2022 - 16:02 UTC
Investigating
Explorer Unavailable

The core team is aware that explorer is not displaying accurate data at the moment. We've alerted our provider and they've started looking into it. Apologies for the inconvenience.

Hotspots, tokens are safe. The blockchain is still moving.

I'll be back in 30 minutes or less.
Posted Aug 23, 2022 - 15:36 UTC
This incident affected: Explorer.