Long Election Block @ 1367289

Incident Report for Helium

Resolved

We’ve progressed past another election and block times are back to normal.
Posted May 24, 2022 - 21:30 UTC

Identified

The core developers have identified the cause of the slow block. It is likely due to the chain variable that was issued right before the election causing some validators to have trouble absorbing the election block.

We will continue to provide updates and clear this issue as more blocks are produced.
Posted May 24, 2022 - 20:30 UTC

Investigating

The core developers are investigating what looks like a large election block @ 1367289. Validators operators currently in the Consensus Group, please join us on Discord.

We will provide updates as we learn more but our current evaluation of the situation is that a large block was produced and is now being absorbed.
Posted May 24, 2022 - 20:18 UTC
This incident affected: Consensus Groups.