Investigating: Error 522

Incident Report for Helium

Resolved

Resolved: Error 522 (Connection Timeout)
We’ll continue monitoring to ensure stability. Thank you for your patience while we worked to resolve this.
Posted Aug 22, 2025 - 18:28 UTC

Investigating

We are currently investigating reports of Error 522 (Connection Timeout) affecting some users during onboarding and hotspot updates.

Impact: users may see a timeout or error message when attempting to complete payments or update antenna information.
Scope: Issue appears intermittent and does not affect all devices.
Current Status: Our engineering team has identified this as potentially related to recent application updates. A fix is being tested.

We’ll provide updates here as we learn more. Thank you for your patience.
Posted Aug 22, 2025 - 17:23 UTC
This incident affected: User Interactions (IoT Hotspot Onboarding).