Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 14, 2025 - 08:00 UTC
Scheduled
Helium will be performing maintenance on the Brownfield Radiator system to improve stability and performance. During this time, Brownfield (Helium Plus) networks may experience brief service interruptions.
Impact:
Applies to brownfield setups only Short service interruptions may occur during the migration window Helium will monitor the process closely to minimize disruption. No changes are needed from deployers.
Posted Oct 13, 2025 - 18:27 UTC
This scheduled maintenance affected: Mobile (Brownfield Wi-Fi Hotspots) and Helium Backend (Radiator).