Active upstream carrier 2 offload outage

Incident Report for Helium

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 14:44 UTC

Monitoring

Monitoring and awaiting resolution.
Posted Jul 28, 2026 - 01:28 UTC

Identified

Carrier 2 general outage. Awaiting resolution.
Posted Jul 27, 2026 - 23:43 UTC

Investigating

Investigating connectivity issue affecting upstream carrier traffic with carrier 2.
Posted Jul 27, 2026 - 23:17 UTC
This incident affected: Mobile (Helium Mobile Wi-Fi Hotspots, Brownfield Wi-Fi Hotspots).