A backend patch has been applied to address issues with Hotspots failing to submit speed tests. If you’re still seeing problems, a reboot should fix it. We’ll continue to monitor.
Posted Sep 03, 2025 - 13:47 UTC
Identified
Following the recent Mobile Oracle infrastructure migration, the team has noticed that a subset of HMHs are failing to submit speed tests. The lack of speed tests will prevent a Hotspot from receiving Proof of Coverage rewards. A backend patch has been applied which will likely address the issue without operator intervention. However, if you notice your HMH is failing to submit speed tests, a simple reboot should resolve the issue.
Posted Aug 29, 2025 - 22:11 UTC
This incident affects: Mobile (Helium Mobile Wi-Fi Hotspots).