Helium API Service Scheduled Maintenance Continues

Incident Report for Helium

Resolved

Explorer and the Helium Apps are now back. Thanks for everyone's patience during this extended maintenance period.
Posted Nov 17, 2022 - 20:25 UTC

Update

Explorer and Apps are syncing back up but still about 200 blocks behind.
Posted Nov 17, 2022 - 19:10 UTC

Update

GM. The API is still down. During the maintenance, a corrupt database affected how all services could be brought back up. As a result, over 170TB of data had to be rebuilt from scratch.

The main database is up but in order to service all our users and services, we need several more instances.
Posted Nov 17, 2022 - 15:23 UTC

Identified

The API is still down at this time. Databases are being brought up to restore services to the Apps, Explorer, and allow pending transactions first. The Public API will return after the other services are back up. We expect that this will be back online in the morning Pacific Time. An update will be provided then if anything changes.
Posted Nov 17, 2022 - 07:06 UTC

Update

The API is still down at this time. Databases are being brought up to restore services to the Apps, Explorer, and allow pending transactions first. The Public API will return after the other services are back up.

Please also note that the chain is currently halted, and the Validator operators are working to get the chain moving again.
Posted Nov 17, 2022 - 04:15 UTC

Update

Quick update on the API:

Services are slowly being brought back up. This will take time as there is a lot of data to move around. That said, our API provider expects all Helium Apps to be back up in the next 4-5 hours and pending transactions re-enabled in 4-5 hours as well.

The public API will not return for about 8 more hours.
Posted Nov 16, 2022 - 18:07 UTC

Investigating

The Helium API Service is still offline due to unforeseen issues during the maintenance window. The team is working through a resolution and will update time of resolution as soon as possible.

During this time:
▫️Submitting transactions will be unavailable in the Helium Hotspot App and Helium Wallet App. (Transactions include Add Hotspot, Assert Location, Payments, Burns, and Transfer Hotspots)
▫️ Information displayed in the Hotspot App, Wallet App, and Explorer will be unavailable, out-of-date, or delayed.
▫️ Mining, Rewards, and data transfer are not affected, but their transactions will be delayed until the maintenance is over.

While the main Helium API is still down, you might be able to do what you’re trying to do using community data sources such as:
https://hotspotty.net/
https://hntscan.io/
https://www.heliumboard.com/
https://heliumtracker.io/
https://heliumgeek.com/

Give some of these tools developed by the Helium community a spin!
Posted Nov 16, 2022 - 16:37 UTC
This incident affected: User Apps (Helium Wallet App, Blockchain, API) and Explorer, Helium App.