App and Explorer blockchain data is behind
Incident Report for Helium
Resolved
A service was restarted and both App and Explorer are back and displaying up-to-date blockchain data.
Posted Mar 01, 2022 - 17:16 UTC
Investigating
The database that serves data to the App and Explorer is behind and undergoing emergency maintenance. Pending transactions may be delayed.

Transactions include:
- payments
- transfer Hotspots
- add hotspots, update location
- burn transactions

Funds are safe, Hotspot mining is unaffected, the chain is still moving.

status.helium.com
Posted Mar 01, 2022 - 15:33 UTC
This incident affected: Explorer and Helium App.