Helium Wallet - RPC Degraded Performance

Incident Report for Helium

Resolved

This issue is now resolved. Realms and the Helium Wallet are back to normal operations.
Posted Jul 04, 2023 - 05:11 UTC

Update

In furtherance to the Solana RPC degraded performance, we have identified additional impacts affecting Realms and are continuing to coordinate with the third party provider on resolution.
Posted Jul 04, 2023 - 02:34 UTC

Identified

We have identified an issue with the Solana RPC and are coordinating with the third party provider on resolution. Helium Wallet App performance may be degraded at this time.
Posted Jul 04, 2023 - 01:07 UTC
This incident affected: Helium App.