Elevated carrier reject rate

Incident Report for Helium

Monitoring

The carrier partner has resolved the issue. We continue to monitor metrics.
Posted Sep 18, 2026 - 21:37 UTC

Investigating

The network is experiencing an abnormally high reject rate from one of our carrier partners. We are actively working with them to resolve it.
Posted Sep 18, 2026 - 21:20 UTC
This incident affects: Mobile (Helium Mobile Wi-Fi Hotspots, Brownfield Wi-Fi Hotspots) and Helium Backend (Radiator).