World Explorer Degraded Service

Incident Report for Helium

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 19:54 UTC

Identified

An upstream service is causing some Hotspots to fail to load. The team is investigating the issue and will deploy a fix shortly.
Posted Jan 27, 2026 - 17:57 UTC
This incident affected: User Apps (World Explorer).