Service Issues with Private API
Incident Report for Helium
Resolved
Things are back! Thanks
Posted Mar 22, 2022 - 21:01 UTC
Monitoring
We've identified a second user that was helping to degrade things. These two users have been banned and the APIs are starting to fully recover.
Posted Mar 22, 2022 - 20:52 UTC
Investigating
We are having service issues with the API that support helium APPs and Explorer. We've identified a users making 10s of thousands of request and likely causing the problem. Unfortunately this issue has cascaded and will take some time to recover. More details soon while we continue to investigate.
Posted Mar 22, 2022 - 20:43 UTC
This incident affected: User Apps (Helium Wallet App, Blockchain, API).