App and Explorer Data unable to load
Incident Report for Helium
Resolved
The issue was an increase in inbound requests. Things are back to normal now. If you're still having issues, please force close the app or open explorer in a new tab.
Posted Apr 08, 2022 - 19:52 UTC
Investigating
The API (the service that provide blockchain information to both the App and Explorer) is experiencing an intermittent outage. At this time, users may not be able to see Hotspot details, Wallet balances, or submit transactions to the blockchain.

The chain is still moving, your funds are safe, and Hotspots are still mining.
Posted Apr 08, 2022 - 18:09 UTC
This incident affected: User Apps (API) and Explorer, Helium App.