Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 09, 2025 - 10:00 UTC
Scheduled
The Core team is activating Demand Sampling for Helium Mobile Hotspots. This functionality will allow newly asserted Hotspots to handle unrewarded carrier traffic for a period of two weeks in order to better determine eligibility for full offload activation. Hotspots with activated MNO carrier offload are unaffected.
This feature is being enabled via a configuration change without additional firmware updates. No user action is required.
Posted Dec 08, 2025 - 18:10 UTC
This scheduled maintenance affected: Mobile (Helium Mobile Wi-Fi Hotspots).