The technical issue impacting service has been resolved. Carrier traffic has stabilized. We’ll continue monitoring to ensure everything remains nominal.
Posted Nov 23, 2025 - 00:01 UTC
Identified
The issue appears to stem from a recent software update on the carrier's side and we’re actively collaborating on a fix with our partner. Traffic from other carriers remains unaffected.
We’ll share more updates as progress continues but we're not expecting any updates until Monday at the earliest.
Posted Nov 15, 2025 - 17:54 UTC
Investigating
We’re seeing reduced traffic from one carrier starting yesterday. Other carriers are unaffected. We are collaborating with the carrier to understand the behavior. We’ll update once we have more details.
Posted Nov 15, 2025 - 00:57 UTC
This incident affected: Mobile (Helium Mobile Wi-Fi Hotspots, Brownfield Wi-Fi Hotspots).