Helium Wallet / RPC Outage
Incident Report for Helium
Resolved
The core developers have verified with the RPC provider that a bad configuration was inadvertently deployed. This configuration has been fixed and the Helium community should no longer see this particular issue.
Posted May 27, 2023 - 23:19 UTC
Monitoring
We are seeing normal activity on Explorer and the Wallet app. Devs will continue to monitor the situation and close the issue after confirming recovery.
Posted May 27, 2023 - 23:13 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 27, 2023 - 22:57 UTC
Identified
The community and core developers have noticed that apps like the Explorer and Helium Wallet app are experiencing a degraded performance due to downstream RPC provider errors. Core developers are working with the provider to ensure service is restored soon.

In the meantime, the apps may show incorrect data and transactions may not submit at this time. This should resolve as soon as the RPC provider is back online.
Posted May 27, 2023 - 22:00 UTC
This incident affected: Explorer and Helium App.