ETL Stuck at block height 1138180
Incident Report for Helium
Resolved
ETL is completely caught up and the large pending transaction queue has cleared. There are a few performance improvements to push out and those will be announced on our Discord channel when they're ready.
Posted Dec 13, 2021 - 21:24 UTC
Update
A new build with the bug fix is now available for ETL developers to pull and apply.
Posted Dec 13, 2021 - 19:45 UTC
Identified
A fix has been identified and is being deployed in the next 20 minutes.
Posted Dec 13, 2021 - 19:21 UTC
Update
Update: Because ETL is stuck, all transactions will remain pending until further notice. If you submitted a transaction, it will not clear until ETL is back up and transactions are processed.

All transaction types will be pending until ETL is back:
* Add Hotspot
* Update Location
* Payment Transactions
* Transfer Hotspot
* Burn transactions
Posted Dec 13, 2021 - 19:03 UTC
Investigating
The team is investigating an issue where ETL is stuck at block height 1138180. The chain is still moving, mining rewards, and data transfer are not affected. However, users of ETL including Explorer will show a stuck block height.
Posted Dec 13, 2021 - 18:36 UTC
This incident affected: User Apps (API) and Explorer, Helium App.