Cloudflare Outage

Incident Report for Helium

Resolved

Cloudflare services have recovered.
Posted Nov 18, 2025 - 15:06 UTC

Identified

Due to the current Cloudflare outage worldwide, some services are currently unavailable. We are monitoring the situation and will post updates here as they become available.
Posted Nov 18, 2025 - 14:36 UTC
This incident affected: User Apps (Builder App, World Explorer, Hotspot Dashboard (IMS)).