After a period of observation, we are satisfied with the stability and performance improvements in Solana transaction processing.
Posted May 08, 2024 - 19:41 UTC
Verifying
The maintenance to improve Solana transaction processing is complete. We are now verifying for stability and performance.
Posted May 08, 2024 - 17:29 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 08, 2024 - 16:31 UTC
Scheduled
After addressing the minor issues from yesterday's maintenance, the Helium Wallet API will undergo another maintenance in order to improve Solana transaction processing.