Decrease in Hotspot Heartbeats

Incident Report for Helium

Resolved

We've resolved an issue affecting network connectivity, caused by a certificate issue. The certificate has been corrected, and we've implemented additional monitoring to detect and prevent this type of issue going forward.
Posted Jul 13, 2026 - 15:23 UTC

Investigating

We’re observing an increase in hotspot heartbeat issues and are currently investigating. We will continue to keep the community updated.
Posted Jul 12, 2026 - 16:53 UTC
This incident affected: Mobile (Helium Mobile Wi-Fi Hotspots).