RPC Service Degraded
Incident Report for Helium
Resolved
This incident has been resolved.
Posted Apr 21, 2023 - 03:17 UTC
Monitoring
The RPC service is back online. We will be monitoring its performance to ensure it stays stable.
Posted Apr 21, 2023 - 02:29 UTC
Identified
The backend RPC service that the Helium Wallet App uses to claim network rewards and that the Helium Explorer uses to collect network statistics is under heavy load from a large Solana minting event. This unfortunately means that Helium Wallet App users will be unable to claim rewards until the load subsides. We are coordinating with the RPC service provider to improve service reliability.
Posted Apr 21, 2023 - 01:37 UTC
Update
A backend RPC service is experiencing a partial outage, which is causing errors in both the Helium Explorer and the Wallet App. This might affect users who are attempting to claim IOT and MOBILE rewards through the Wallet App.
Posted Apr 21, 2023 - 00:20 UTC
Investigating
A backend RPC service is experiencing a partial outage, which is causing errors in both the Helium Explorer and the Wallet App.
Posted Apr 21, 2023 - 00:15 UTC
This incident affected: User Apps (Helium Wallet App) and Explorer.