App and Explorer Data unable to load
Incident Report for Helium
Resolved
This incident has been resolved.
Posted Apr 11, 2022 - 21:03 UTC
Investigating
We're seeing reports of slowness in the Hotspot app related to loading blockchain data, Hotspot data, and even adding Hotspots to the blockchain.

We're aware of the situation and investigating. We'll provide an update once we know more.
Posted Apr 11, 2022 - 19:16 UTC
This incident affected: User Apps (API) and Helium App.