Helium Wallet / RPC Outage
Incident Report for Helium
Resolved
This incident has been resolved.
Posted May 12, 2023 - 01:39 UTC
Monitoring
The data provider has completed the migration process and Wallet app services have been restored.

We will continue monitoring to ensure stability is maintained.
Posted May 11, 2023 - 23:49 UTC
Identified
Core developers have identified an issue with a downstream data provider undergoing a migration process that is causing Helium Wallet app actions to be degraded. At this time, data in the wallet may be inaccurate or out of date and transactions may fail.

We are working with this provider to ensure that services can be restored soon.
Posted May 11, 2023 - 21:24 UTC
This incident affected: Helium App.