Blockchain outage
Incident Report for Helium
Resolved
The core developers continue to monitor the chain. A follow up release for Hotspots will be issued once a snapshot without the large block that caused issues is agreed upon by the Consensus Group.
Posted Nov 21, 2021 - 01:47 UTC
Monitoring
With Consensus Group Validators upgrading to 1.5.12 and restarting, block production has resumed. Thank you Validator community for responding quickly to this blockchain halt. The core developers will continue to monitor the chain over the evening.

We recommend all Validator operators upgrade to 1.5.12 as soon as possible.

Console/Router continues to be degraded until we are able to issue a miner snapshot that is past the most recent large block that caused the halt.
Posted Nov 21, 2021 - 01:09 UTC
Update
While Console/Router continue to send packets, devices relying primarily on older or underpowered Hotspots (less than 1GB RAM) are experiencing problems with data transfer. The core developers are working to push out a new image for these Hotspots as soon as possible. Devices in areas with redundant coverage are not affected.
Posted Nov 20, 2021 - 23:56 UTC
Update
The team is making a new tagged release for validators that will help move the consensus group along and produce blocks more consistently. Will provide another update when we have a tag available for Validators
Posted Nov 20, 2021 - 23:23 UTC
Investigating
The large block has caused a blockchain outage. The team is investigating. At this time, transactions will not go through, Hotspots cannot be added. Your funds remain safe.
Posted Nov 20, 2021 - 20:49 UTC
This incident affected: User Apps (Blockchain) and Consensus Groups, Helium Packet Router.