Helium Wallet / RPC Degraded Performance
Incident Report for Helium
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 17:34 UTC
Monitoring
The fix appears to have addressed the issue but we will continue to monitor to ensure stability is maintained.
Posted Jun 09, 2023 - 16:36 UTC
Identified
The issue has been identified and a potential fix has been deployed.
Posted Jun 09, 2023 - 15:43 UTC
Investigating
We are currently investigating an issue with the RPC with the third party provider. Explorer and Helium Wallet App performance may be degraded at this time.
Posted Jun 09, 2023 - 15:05 UTC
This incident affected: Explorer and Helium App.