Solana Network Congestion
Incident Report for Helium
Resolved
This incident has been resolved.
Posted May 02, 2024 - 16:54 UTC
Identified
Due to high Solana congestion, transactions may fail or be delayed. Please retry failed transactions.
Posted Apr 06, 2024 - 00:18 UTC
This incident affected: User Apps (Helium Wallet App).