Add Gateway transactions for Full Hotspots Failing to Validate
Incident Report for Helium
Resolved
We are closing this incident as we have seen several Hotspots successfully add themselves to the chain. Sorry for the inconvenience.
Posted Jul 20, 2021 - 22:21 UTC
Monitoring
The core developers have issued the chain variable and have noticed new Add Gateway transactions clear as expected. We are moving to monitoring the chain for any subsequent issues.
Posted Jul 20, 2021 - 22:08 UTC
Update
The core developers will be updating the Data-Only hotspots chain variable to roll forward through this partial outage. We have identified that an empty list of staking keys was an incorrect default value for this variable.
Posted Jul 20, 2021 - 21:53 UTC
Identified
The core developers are currently looking into an issue where Add Gateway transactions are failing due to a recently issued chain variable for Data-Only Hotspots. We will be issuing a new Chain Variable to unset this value shortly.

The blockchain is still producing blocks, other transactions are flowing normally, and all other activity is as expected.
Posted Jul 20, 2021 - 21:20 UTC
This incident affected: User Apps (Blockchain, API).