Public HTTP API Potential Denial of Service
Incident Report for Helium
Resolved
We have found the offending source making 15K requests a second against the public api. The rate limiter was working but it was not enough to stop a cascading overload on all of the public api databases. We will monitor closely and make sure they do not try again from a different origin. Thanks for your patience.
Posted Feb 18, 2022 - 12:36 UTC
Investigating
We are currently overloaded on the public api instances for the Helium HTTP API (15000 requests sec). This does not affect explorer or the apps or helium votes. We are investigating now and working to block the culprit.
Posted Feb 18, 2022 - 12:24 UTC
This incident affected: User Apps (API).